NINA Forum

Full Version: [GUIDE] Resolving 80048821 error for Messenger 4.7 and 5+ on Windows XP and Vista
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
The following guide was originally written by user ThatXPUser on our Discord server. Please take into account this solution isn't 100% for everyone, and that it's only confirmed to work for users using Windows XP on an x86 architecture, or any edition of Windows Vista. This guide also doesn't take into account the recent loss of Windows Update capabilities on XP, Vista, and Windows 7 as it was written before that took place, and since that was necessary for Vista to have up-to-date root certificates you will currently have to seek those out on your own before referring to the guide.

This guide also assume you already have a patched installation of the Messenger client you plan to use. If you have an unpatched version (like stock 4.7 on XP SP3, as an example), then that's out of this post's scope. You will have to consult Escargot's official patching instructions or elsewhere before following this. We also recommend you upgrade your Internet Explorer version on the target OS to version 8 or the maximum your OS will support if you haven't already as this apparently upgrades the system SSL libraries and increases your chances of getting secure MSN versions working.

After following this guide, if you intend to use WLM 8 or 2009 (not currently supported) on XP (or Vista if you really have to), then follow this guide on setting up ProxHTTPSProxy to improve reliability in HTTPS sessions. You need to do this as starting with WLM 8 communicating with the service involves HTTPS requests for core functions like contact lists and roaming display picture/PSM, among a few others. Without setting Prox up your WLM experience on XP will be spotty, to say the least.



So, to get MSN on XP and Vista (defeating the 80048821 error MAY NOT WORK ON x64), you first download this tool https://msfn.org/board/topic/175170-root...nt-1110568 (you'll need a modern browser like Mozilla Firefox to open this webpage and you also need 7-Zip or WinRAR to extract it, the password is in the webpage)

After that run it as the readme on the 7z file tells you, and after that you open Control Panel, open Internet Settings, go to the Advanced tab, scroll until you find SSL and TLS and make sure the only options enabled are TLS:

[Image: internet-properties.png]

Now all of the MSN versions should work fine, they just need some login attempts before working. Note: on Vista you want to try https://msfn.org/board/topic/176902-enab...xplorer-9/
Quote:After following this guide, if you intend to use WLM 8 or 2009 (not currently supported) on XP (or Vista if you really have to), then follow this guide on setting up ProxHTTPSProxy to improve reliability in HTTPS sessions. You need to do this as starting with WLM 8 communicating with the service involves HTTPS requests for core functions like contact lists and roaming display picture/PSM, among a few others. Without setting Prox up your WLM experience on XP will be spotty, to say the least.
As you said the experience will be quite annoying but i couldn't get WLM working with this guide only, i'd have to set up TLS 1.1&1.2 to get it working, ProxHTTPSProxy never worked for me so thats what i use ¯\_(ツ)_/¯